summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 746b901..80196d9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -31,11 +31,17 @@ include_directories(
${BOOST_INCLUDE_DIRS}
)
-set(SOURCES
+set(SOURCES_CLIENT
"${CMAKE_SOURCE_DIR}/UDPClient/UDPClient.cpp"
"${CMAKE_SOURCE_DIR}/main.cpp"
)
-add_executable(onlineDetectorSimulator ${SOURCES})
+set(SOURCES_SERVER
+ "${CMAKE_SOURCE_DIR}/UDPServer/UDPServer.cpp"
+ "${CMAKE_SOURCE_DIR}/main_server.cpp"
+)
+
+add_executable(onlineDetectorSimulatorServer ${SOURCES_SERVER})
+add_executable(onlineDetectorSimulatorClient ${SOURCES_CLIENT})