summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..29c8422
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,17 @@
+if (NOT WIN32)
+ SET(BUILD_SHARED_LIBS ON)
+endif (NOT WIN32)
+
+SET(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+SET(HEADERS
+ librcd.h
+)
+
+SET(rcd_SRCS
+ librcd.c
+ russian_table.h
+ ${HEADERS}
+)
+
+ADD_LIBRARY(rcd ${rcd_SRCS})