summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2008-11-20 16:37:23 +0000
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2008-11-20 16:37:23 +0000
commit0a7946350f4f9a4873066789f5eaeba47130047d (patch)
tree24a6cd18abf28e0762e142443b910c158a8344db /debian
parent6c692c9f6762f0490307294e098b7ce1a8d46611 (diff)
downloadlibrcd-0a7946350f4f9a4873066789f5eaeba47130047d.tar.gz
librcd-0a7946350f4f9a4873066789f5eaeba47130047d.tar.bz2
librcd-0a7946350f4f9a4873066789f5eaeba47130047d.tar.xz
librcd-0a7946350f4f9a4873066789f5eaeba47130047d.zip
Debian support by Ivan Borzenkov
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control22
-rw-r--r--debian/copyright19
-rw-r--r--debian/librcd-dev.dirs2
-rw-r--r--debian/librcd-dev.install4
-rw-r--r--debian/librcd.dirs1
-rw-r--r--debian/librcd.install1
-rw-r--r--debian/rules100
-rw-r--r--debian/watch23
10 files changed, 179 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..2b63a15
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+librcd (0.1.11-1) unstable; urgency=low
+
+ * Initial release
+
+ -- Ivan Borzenkov <ivan1986@list.ru> Sun, 16 Nov 2008 03:17:57 +0300
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..bdc6d44
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,22 @@
+Source: librcd
+Priority: extra
+Maintainer: Ivan Borzenkov <ivan1986@list.ru>
+Build-Depends: debhelper (>= 7)
+Standards-Version: 3.7.3
+Section: libs
+Homepage: http://rusxmms.sourceforge.net/
+
+Package: librcd
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Russian Charset Detection Library
+ Library for autodection charset of russian text
+
+Package: librcd-dev
+Section: libdevel
+Architecture: any
+Depends: librcd (= ${binary:Version})
+Description: Russian Charset Detection Library - dev files
+ Library for autodection charset of russian text
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..4a8a881
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,19 @@
+This package was debianized by Ivan Borzenkov <ivan1986@list.ru> on
+Sun, 16 Nov 2008 03:17:57 +0300.
+
+It was downloaded from http://rusxmms.sourceforge.net/
+
+Upstream Author(s):
+
+ Suren A. Chilingaryan <csa@dside.dyndns.org>
+
+Copyright:
+
+ Copyright (C) 2005 Suren A. Chilingaryan
+
+License:
+
+ GPL
+
+The Debian packaging is (C) 2008, Ivan Borzenkov <ivan1986@list.ru> and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
diff --git a/debian/librcd-dev.dirs b/debian/librcd-dev.dirs
new file mode 100644
index 0000000..4418816
--- /dev/null
+++ b/debian/librcd-dev.dirs
@@ -0,0 +1,2 @@
+usr/lib
+usr/include
diff --git a/debian/librcd-dev.install b/debian/librcd-dev.install
new file mode 100644
index 0000000..f882277
--- /dev/null
+++ b/debian/librcd-dev.install
@@ -0,0 +1,4 @@
+usr/include/*
+usr/lib/lib*.a
+usr/lib/lib*.so
+usr/lib/*.la
diff --git a/debian/librcd.dirs b/debian/librcd.dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian/librcd.dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian/librcd.install b/debian/librcd.install
new file mode 100644
index 0000000..d0dbfd1
--- /dev/null
+++ b/debian/librcd.install
@@ -0,0 +1 @@
+usr/lib/lib*.so.*
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 0000000..0069a8a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,100 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# shared library versions, option 1
+version=0.1.11
+major=0
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+#version=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+#major=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ ./autogen.sh
+
+ dh_auto_configure
+
+ touch configure-stamp
+
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ test ! -f Makefile || $(MAKE) clean distclean distclean-am
+ rm -f examples/Makefile statgen/Makefile
+
+ dh_auto_clean
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..d0eccee
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,23 @@
+# Example watch control file for uscan
+# Rename this file to "watch" and then you can run the "uscan" command
+# to check for upstream updates and more.
+# See uscan(1) for format
+
+# Compulsory line, this is a version 3 file
+version=3
+
+# Uncomment to examine a Webpage
+# <Webpage URL> <string match>
+#http://www.example.com/downloads.php librcd-(.*)\.tar\.gz
+
+# Uncomment to examine a Webserver directory
+http://dside.dyndns.org/files/rusxmms/librcd-(.*)\.tar\.gz
+
+# Uncommment to examine a FTP server
+#ftp://ftp.example.com/pub/librcd-(.*)\.tar\.gz debian uupdate
+
+# Uncomment to find new files on sourceforge, for devscripts >= 2.9
+# http://sf.net/librcd/librcd-(.*)\.tar\.gz
+
+# Uncomment to find new files on GooglePages
+# http://example.googlepages.com/foo.html librcd-(.*)\.tar\.gz