summaryrefslogtreecommitdiffstats
path: root/x11-themes/ds-themes/ds-themes-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/ds-themes/ds-themes-1.0.ebuild')
-rw-r--r--x11-themes/ds-themes/ds-themes-1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/ds-themes/ds-themes-1.0.ebuild b/x11-themes/ds-themes/ds-themes-1.0.ebuild
new file mode 100644
index 0000000..3c93f46
--- /dev/null
+++ b/x11-themes/ds-themes/ds-themes-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="GTK themes"
+HOMEPAGE="http://www.windowmaker.org/"
+
+THEME_URI="http://dside.dyndns.org/files/darklin/themes"
+SRC_URI="${THEME_URI}/aquax-gtk2-default-1.0-rc1.tar.gz
+ ${THEME_URI}/gnuaquase-default-0.5.tar.gz
+ ${THEME_URI}/h2o-gtk2-default-2.0.tar.gz
+ ${THEME_URI}/gtk-themes-extra-4.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ppc sparc x86"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ for i in ${SRC_URI} ; do
+ bn=`basename $i`
+ unpack ${bn}
+ done
+}
+
+src_install () {
+ dodir /usr/share/themes
+ cp -pR * ${D}/usr/share/themes/
+ chown -R root:0 ${D}/usr/share/themes/
+ chmod -R o-w ${D}/usr/share/themes/
+
+ dodir /etc/gtk
+ install -m 644 ${FILESDIR}/gtkrc ${D}/etc/gtk/
+}