summaryrefslogtreecommitdiffstats
path: root/x11-terms/xterm/xterm-243-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/xterm/xterm-243-r1.ebuild')
-rw-r--r--x11-terms/xterm/xterm-243-r1.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/x11-terms/xterm/xterm-243-r1.ebuild b/x11-terms/xterm/xterm-243-r1.ebuild
new file mode 100644
index 0000000..2e869cf
--- /dev/null
+++ b/x11-terms/xterm/xterm-243-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-243.ebuild,v 1.1 2009/05/05 12:41:03 ssuominen Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
+IUSE="truetype Xaw3d unicode toolbar"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXft
+ x11-libs/libXaw
+ x11-apps/xmessage
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/Xaw3d )
+ sys-libs/libutempter"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+pkg_setup() {
+ DEFAULTS_DIR="/usr/share/X11/app-defaults"
+}
+
+#SDS
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+#MDK
+# epatch ${FILESDIR}/xterm-199-biarch-utmp.patch.bz2
+# epatch ${FILESDIR}/xterm-197-alt-keysym-index.patch.bz2
+# epatch ${FILESDIR}/xterm-199-alt-meta-mod.patch.bz2
+
+#DarkLin
+ epatch ${FILESDIR}/xterm-ds-metaesc.patch || die
+ epatch ${FILESDIR}/xterm-ds-config.patch || die
+ epatch ${FILESDIR}/xterm-ds-sm-243.patch || die
+ epatch ${FILESDIR}/xterm-ds-paste-225.patch || die
+ epatch ${FILESDIR}/xterm-ds-input-225.patch || die
+ epatch ${FILESDIR}/xterm-ds-copy-243.patch || die
+# Embedded in SM patch
+## epatch ${FILESDIR}/xterm-ds-utf8mode.patch
+}
+#EDS
+
+src_configure() {
+ filter-flags "-fstack-protector"
+ replace-flags "-Os" "-O2" # work around gcc-4.1.1-r[01] bugs
+
+ econf --libdir=/etc \
+ --with-x \
+ --with-utempter \
+ --disable-setuid \
+ --disable-full-tgetent \
+ --disable-imake \
+ --disable-narrowproto \
+ --enable-ansi-color \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-load-vt-fonts \
+ --enable-i18n \
+ --enable-wide-chars \
+ --enable-doublechars \
+ --enable-warnings \
+ --enable-tcap-query \
+ --enable-logging \
+ --enable-dabbrev \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ --x-libraries="${ROOT}usr/lib" \
+ $(use_enable toolbar) \
+ $(use_enable truetype freetype) \
+ $(use_enable unicode luit) $(use_enable unicode mini-luit) \
+ $(use_with Xaw3d)
+}
+
+# Parallel make causes File exists error and dies. Forcing -j1 for now.
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ dodoc README{,.i18n} ctlseqs.txt
+ dohtml xterm.log.html
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i "s:blue2$:blue:" "${D}"${DEFAULTS_DIR}/XTerm-color
+
+ # Fix for bug #91453 at Thomas Dickey's suggestion:
+ echo "*allowWindowOps: false" >> "${D}"/${DEFAULTS_DIR}/XTerm
+ echo "*allowWindowOps: false" >> "${D}"/${DEFAULTS_DIR}/UXTerm
+}
+
+pkg_postinst() {
+ elog "bracketed paste mode requires the allowWindowOps resource to be true"
+ elog "which is false by default for security reasons (see bug #91453)."
+ elog "To be able to use it add 'allowWindowOps: true' to your resources"
+}