summaryrefslogtreecommitdiffstats
path: root/x11-plugins/wmvolman/wmvolman-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmvolman/wmvolman-2.0.1.ebuild')
-rw-r--r--x11-plugins/wmvolman/wmvolman-2.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmvolman/wmvolman-2.0.1.ebuild b/x11-plugins/wmvolman/wmvolman-2.0.1.ebuild
new file mode 100644
index 0000000..47f6bd9
--- /dev/null
+++ b/x11-plugins/wmvolman/wmvolman-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.3.ebuild,v 1.1 2006/10/31 05:03:51 vericgar Exp $
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Dockable applet for WindowMaker that handles hotpluggable devices and removable media."
+SRC_URI="https://github.com/raorn/${PN}/archive/${PV}.tar.gz"
+HOMEPAGE="http://people.altlinux.ru/~raorn/wmvolman.html"
+
+DEPEND="sys-fs/udisks:2
+ >=x11-libs/libdockapp-0.6.0
+ >=dev-libs/glib-2.31.13"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ eautoreconf || die
+ econf --prefix="/usr"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" PREFIX="/usr" install || die "make install failed"
+ dodoc README AUTHORS NEWS
+}