summaryrefslogtreecommitdiffstats
path: root/x11-plugins/wmauda/wmauda-0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmauda/wmauda-0.8.ebuild')
-rw-r--r--x11-plugins/wmauda/wmauda-0.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-plugins/wmauda/wmauda-0.8.ebuild b/x11-plugins/wmauda/wmauda-0.8.ebuild
new file mode 100644
index 0000000..f0fbfa9
--- /dev/null
+++ b/x11-plugins/wmauda/wmauda-0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.7.ebuild,v 1.4 2008/01/15 17:58:26 opfer Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockable applet for WindowMaker that controls Audacious."
+HOMEPAGE="http://www.netswarm.net"
+SRC_URI="http://www.netswarm.net/misc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libX11
+ >=x11-libs/gtk+-2
+ media-libs/libaudclient"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack "${P}.tar.gz" || die "unpacking failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/link-against-missing-libraries.patch || die "patch failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed."
+ dodoc AUTHORS README
+}