summaryrefslogtreecommitdiffstats
path: root/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r1.ebuild')
-rw-r--r--x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r1.ebuild b/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r1.ebuild
new file mode 100644
index 0000000..a5587eb
--- /dev/null
+++ b/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-xkb/gkrellm-xkb-1.05.ebuild,v 1.3 2006/05/29 23:10:48 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="XKB keyboard switcher for gkrellm2"
+HOMEPAGE="http://sweb.cz/tripie/gkrellm/xkb/"
+SRC_URI="http://sweb.cz/tripie/gkrellm/xkb/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~amd64"
+IUSE=""
+
+DEPEND=">=app-admin/gkrellm-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gkrellm-xkb-ds-subs.patch || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/lib/gkrellm2/plugins
+ doins xkb.so
+ dodoc AUTHORS LICENSE ChangeLog
+}