summaryrefslogtreecommitdiffstats
path: root/x11-libs/vte/vte-0.30.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/vte/vte-0.30.1-r3.ebuild')
-rw-r--r--x11-libs/vte/vte-0.30.1-r3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/vte/vte-0.30.1-r3.ebuild b/x11-libs/vte/vte-0.30.1-r3.ebuild
new file mode 100644
index 0000000..b852849
--- /dev/null
+++ b/x11-libs/vte/vte-0.30.1-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1-r2.ebuild,v 1.1 2011/11/18 08:48:37 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME terminal widget"
+HOMEPAGE="http://git.gnome.org/browse/vte"
+
+LICENSE="LGPL-2"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc glade +introspection"
+
+PDEPEND="x11-libs/gnome-pty-helper"
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-3.1.9:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXft
+
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+pkg_setup() {
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ G2CONF="${G2CONF}
+ --disable-gnome-pty-helper
+ --disable-deprecation
+ --disable-maintainer-mode
+ --disable-static
+ $(use_enable debug)
+ $(use_enable glade glade-catalogue)
+ $(use_enable introspection)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+}
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=663779
+ epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
+#SDS
+ epatch "${FILESDIR}/${PN}-0.30.1-ds-mc.diff" || die
+#EDS
+
+ gnome2_src_prepare
+}