summaryrefslogtreecommitdiffstats
path: root/www-apps/loggerhead/loggerhead-1.18.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/loggerhead/loggerhead-1.18.1.ebuild')
-rw-r--r--www-apps/loggerhead/loggerhead-1.18.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/www-apps/loggerhead/loggerhead-1.18.1.ebuild b/www-apps/loggerhead/loggerhead-1.18.1.ebuild
new file mode 100644
index 0000000..33c34a3
--- /dev/null
+++ b/www-apps/loggerhead/loggerhead-1.18.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+PV_BASE=$(get_version_component_range 1-2)
+
+DESCRIPTION="A web viewer for projects in Bazaar"
+HOMEPAGE="https://launchpad.net/loggerhead"
+SRC_URI="http://launchpad.net/${PN}/${PV_BASE}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE="apache2 search"
+
+DEPEND=">=dev-python/paste-1.6
+ apache2? ( >=dev-python/pastedeploy-1.3 )"
+RDEPEND="${DEPEND}
+ >=dev-vcs/bzr-1.13
+ dev-python/simpletal
+ dev-python/simplejson
+ search? ( dev-vcs/bzr-search )"
+
+S="${WORKDIR}"/${P}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}"/loggerhead.init loggerhead
+ newconfd "${FILESDIR}"/loggerhead.confd loggerhead
+}