summaryrefslogtreecommitdiffstats
path: root/sys-apps/kbd/kbd-1.15.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kbd/kbd-1.15.1-r1.ebuild')
-rw-r--r--sys-apps/kbd/kbd-1.15.1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/kbd/kbd-1.15.1-r1.ebuild b/sys-apps/kbd/kbd-1.15.1-r1.ebuild
new file mode 100644
index 0000000..9d61056
--- /dev/null
+++ b/sys-apps/kbd/kbd-1.15.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kbd/kbd-1.15.1.ebuild,v 1.2 2009/10/18 18:03:09 vapier Exp $
+
+inherit autotools
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://freshmeat.net/projects/kbd/"
+SRC_URI="ftp://ftp.altlinux.org/pub/people/legion/kbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
+IUSE="nls"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+#SDS
+ epatch "${FILESDIR}"/${PN}-1.15.1-ds-nohost.patch || die
+ epatch "${FILESDIR}"/${PN}-1.14-ds-unicode.patch || die
+#EDS
+
+ eautoreconf # stupid tarball lacks generated autotools
+ sed -i 's:-Werror::' src/Makefile.in
+}
+
+src_compile() {
+#SDS
+ econf $(use_enable nls) --enable-optional-progs || die
+# econf $(use_enable nls) || die
+#EDS
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+#SDS
+ dobin src/spawn_console || die
+ dobin src/spawn_login || die
+
+ tar xjf ${FILESDIR}/keymaps.tar.bz2 -C ${D}/usr/share/keymaps/i386/qwerty || die
+ rm -f ${D}/usr/share/consolefonts/default8x16.psf*.gz
+ ln -s ruscii_8x16.psfu.gz ${D}/usr/share/consolefonts/default8x16.psfu.gz || die
+ tar xjf ${FILESDIR}/console-tools-ds-bin.tar.bz2 -C ${D}/usr/bin || die
+ mkdir -p ${D}/etc/profile.d/
+ install -c -m 755 ${FILESDIR}/alias-console-tools2.sh ${D}/etc/profile.d/ || die
+# install -c -m 755 ${FILESDIR}/consolechars ${D}/usr/bin || die
+
+ mkdir -p ${D}/etc/init.d/
+ install -c -m 755 ${FILESDIR}/dynamicvc ${D}/etc/init.d || die
+
+ mkdir -p ${D}/etc/conf.d/
+ install -c -m 644 ${FILESDIR}/controlkeys ${D}/etc/conf.d || die
+#EDS
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ dohtml doc/*.html
+}