summaryrefslogtreecommitdiffstats
path: root/sci-geosciences/happycamel/happycamel-1_beta3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/happycamel/happycamel-1_beta3-r2.ebuild')
-rw-r--r--sci-geosciences/happycamel/happycamel-1_beta3-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-geosciences/happycamel/happycamel-1_beta3-r2.ebuild b/sci-geosciences/happycamel/happycamel-1_beta3-r2.ebuild
new file mode 100644
index 0000000..019ceaa
--- /dev/null
+++ b/sci-geosciences/happycamel/happycamel-1_beta3-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/gpscorrelate-1.5.6.ebuild,v 1.3 2008/08/23 18:13:05 maekke Exp $
+
+inherit eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="Happy Camel is intended to combine your digital camera with your GPS device"
+HOMEPAGE="http://happycamel.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+DEPEND="virtual/python-imaging
+ media-libs/exiftool"
+
+
+S=${WORKDIR}/${PN}-v${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/happycamel-v1-beta3-ds-features.patch || die
+ epatch "${FILESDIR}"/HappyCamel-optional-correlate.diff || die
+ epatch "${FILESDIR}"/happycamel-ds-icons.patch || die
+}
+
+src_install() {
+ ./setup.py install --root="${D}" --no-compile
+}