summaryrefslogtreecommitdiffstats
path: root/net-misc/httptunnel/httptunnel-3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/httptunnel/httptunnel-3.3-r1.ebuild')
-rw-r--r--net-misc/httptunnel/httptunnel-3.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/httptunnel/httptunnel-3.3-r1.ebuild b/net-misc/httptunnel/httptunnel-3.3-r1.ebuild
new file mode 100644
index 0000000..3911c26
--- /dev/null
+++ b/net-misc/httptunnel/httptunnel-3.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/httptunnel/httptunnel-3.3.ebuild,v 1.4 2005/08/13 23:14:57 hansmi Exp $
+
+DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
+HOMEPAGE="http://www.nocrew.org/software/httptunnel.html"
+LICENSE="GPL-2"
+DEPEND=""
+KEYWORDS="ppc sparc x86 amd64"
+IUSE=""
+SLOT="0"
+#RDEPEND=""
+SRC_URI="http://www.nocrew.org/software/httptunnel/${P}.tar.gz"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodir /etc/conf.d /etc/init.d
+ install -c -m 755 "${FILESDIR}"/htc ${D}/etc/init.d
+ install -c -m 755 "${FILESDIR}"/hts ${D}/etc/init.d
+ install -c -m 644 "${FILESDIR}"/htc.sysconfig ${D}/etc/conf.d/htc
+ install -c -m 644 "${FILESDIR}"/hts.sysconfig ${D}/etc/conf.d/hts
+}
+