summaryrefslogtreecommitdiffstats
path: root/net-analyzer/netams/netams-3.3.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netams/netams-3.3.5.ebuild')
-rw-r--r--net-analyzer/netams/netams-3.3.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/netams/netams-3.3.5.ebuild b/net-analyzer/netams/netams-3.3.5.ebuild
new file mode 100644
index 0000000..7460661
--- /dev/null
+++ b/net-analyzer/netams/netams-3.3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+DESCRIPTION="NetAMS Traffic Accounting"
+SRC_URI="http://www.netams.com/files/netams-${PV}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+RDEPEND="dev-db/mysql net-libs/libpcap"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+# epatch ${FILESDIR}/netams-ds-compile.patch || die
+}
+
+src_compile() {
+ ./configure.sh || die
+ FLAGS=-DHAVE_BW make || die
+}
+
+src_install() {
+ into /usr
+ mkdir -p ${D}/usr/sbin
+ mkdir -p ${D}/etc/init.d
+ mkdir -p ${D}/usr/share/man/man8/
+
+ install -m 0755 ${FILESDIR}/netams33.init ${D}/etc/init.d/netams
+# install -m 0755 addon/netams-gentoo.sh ${D}/etc/init.d/netams
+ install -m 0755 src/flowprobe ${D}/usr/sbin/
+ install -m 0755 src/ipfw2netflow ${D}/usr/sbin/
+ install -m 0755 src/ulog2netflow ${D}/usr/sbin/
+ install -m 0755 src/netams ${D}/usr/sbin/
+ install -m 0755 src/netamsctl ${D}/usr/sbin/
+ install -m 0644 doc/*.8 ${D}/usr/share/man/man8/
+}