summaryrefslogtreecommitdiffstats
path: root/mail-filter/clamassassin/clamassassin-1.2.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/clamassassin/clamassassin-1.2.4-r1.ebuild')
-rw-r--r--mail-filter/clamassassin/clamassassin-1.2.4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/mail-filter/clamassassin/clamassassin-1.2.4-r1.ebuild b/mail-filter/clamassassin/clamassassin-1.2.4-r1.ebuild
new file mode 100644
index 0000000..9623c32
--- /dev/null
+++ b/mail-filter/clamassassin/clamassassin-1.2.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Simple spamassassin-like script for virus scanning and filtering e-mail messages"
+HOMEPAGE="http://jameslick.com/clamassassin/"
+SRC_URI="http://jameslick.com/clamassassin/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="subject-rewrite clamd"
+DEPEND=">=app-antivirus/clamav-0.90
+ sys-apps/debianutils
+ sys-apps/which
+ mail-filter/procmail"
+
+src_compile() {
+ # Try to get location of clamd's DatabaseDirectory
+ local clamav_dbdir=`awk '$1 == "DatabaseDirectory" { print $2 }' \
+ /etc/clamd.conf`
+ # If not defined in clamd.conf, go with default
+ if [ -z "$clamav_dbdir" ] ; then
+ clamav_dbdir="/var/lib/clamav"
+ fi
+ # Add an entry to sandbox write prediction list, so sandbox doesn't complain
+ addpredict ${clamav_dbdir}/
+
+ econf \
+ $(use_enable subject-rewrite) \
+ $(use_enable clamd clamdscan) \
+ || die
+ # Fix problems with Portage exporting TMP and breaking clamassassin. #61806
+ sed -i -e "s:${TMP}:/tmp:" clamassassin
+}
+
+src_install() {
+ dobin clamassassin
+ dodoc CHANGELOG README
+}