summaryrefslogtreecommitdiffstats
path: root/dev-util/decuda/decuda-0.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/decuda/decuda-0.4.2.ebuild')
-rw-r--r--dev-util/decuda/decuda-0.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/decuda/decuda-0.4.2.ebuild b/dev-util/decuda/decuda-0.4.2.ebuild
new file mode 100644
index 0000000..91bc3bb
--- /dev/null
+++ b/dev-util/decuda/decuda-0.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpscorrelate/gpscorrelate-1.5.6.ebuild,v 1.3 2008/08/23 18:13:05 maekke Exp $
+
+inherit eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="Assembler/Disassembler for NVIDIA CUDA binary (.cubin) format"
+HOMEPAGE="http://www.cs.rug.nl/~wladimir/decuda/"
+SRC_URI="http://www.cs.rug.nl/~wladimir/decuda/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+DEPEND="dev-lang/python"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-ds-setup.patch || die
+}
+
+src_install() {
+ python setup.py install --root="${D}" --no-compile
+ dobin cudasm decuda decudaraw
+}