summaryrefslogtreecommitdiffstats
path: root/dev-db/freetds/freetds-0.82-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/freetds/freetds-0.82-r5.ebuild')
-rw-r--r--dev-db/freetds/freetds-0.82-r5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/freetds/freetds-0.82-r5.ebuild b/dev-db/freetds/freetds-0.82-r5.ebuild
new file mode 100644
index 0000000..97c03a6
--- /dev/null
+++ b/dev-db/freetds/freetds-0.82-r5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/freetds-0.64.ebuild,v 1.11 2007/11/14 15:53:32 jer Exp $
+
+inherit eutils
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+DESCRIPTION="Tabular Datastream Library."
+HOMEPAGE="http://www.freetds.org/"
+SRC_URI="http://ibiblio.org/pub/Linux/ALPHA/freetds/stable/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="odbc mssql"
+
+DEPEND="odbc? ( dev-db/unixODBC )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ epatch "${FILESDIR}"/freetds-0.82-odbc-csa2.patch || die
+ epatch "${FILESDIR}"/freetds-ds-connect_timeout.patch || die
+}
+
+src_compile() {
+ local myconf
+ use odbc && myconf="--with-unixodbc=/usr"
+ use mssql && myconf="${myconf} --enable-msdblib"
+ econf --with-tdsver=7.0 ${myconf} --cache-file="${S}/config.cache" || die "econf failed"
+ emake || die "emake failed"
+}
+
+RESTRICT="test"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}