summaryrefslogtreecommitdiffstats
path: root/app-misc/geeknote/geeknote-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/geeknote/geeknote-9999.ebuild')
-rw-r--r--app-misc/geeknote/geeknote-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/geeknote/geeknote-9999.ebuild b/app-misc/geeknote/geeknote-9999.ebuild
new file mode 100644
index 0000000..a635486
--- /dev/null
+++ b/app-misc/geeknote/geeknote-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 eutils distutils-r1 git-2
+
+DESCRIPTION="Console client for Evernote"
+HOMEPAGE="http://geeknote.me"
+
+EGIT_REPO_URI="git://github.com/VitaliyRodnenko/geeknote.git"
+EGIT_BRANCH="master"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+bash-completion"
+
+RDEPEND="
+ bash-completion? ( app-shells/bash-completion )
+ dev-python/html2text
+ dev-python/sqlalchemy
+ dev-python/markdown2
+ dev-python/beautifulsoup:4
+ dev-python/evernote-sdk-python
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_install() {
+
+ if use bash-completion; then
+ dobashcomp ${FILESDIR}/geeknote
+ fi
+
+ distutils-r1_src_install
+}