summaryrefslogtreecommitdiffstats
path: root/app-dicts/libtranslate/libtranslate-0.99-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/libtranslate/libtranslate-0.99-r6.ebuild')
-rw-r--r--app-dicts/libtranslate/libtranslate-0.99-r6.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-dicts/libtranslate/libtranslate-0.99-r6.ebuild b/app-dicts/libtranslate/libtranslate-0.99-r6.ebuild
new file mode 100644
index 0000000..e150735
--- /dev/null
+++ b/app-dicts/libtranslate/libtranslate-0.99-r6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Library for translating text and web pages between natural languages."
+HOMEPAGE="http://www.nongnu.org/libtranslate"
+SRC_URI="http://savannah.nongnu.org/download/libtranslate/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="x86 amd64"
+LICENSE="BSD"
+IUSE=""
+
+
+DEPEND=">=dev-libs/glib-2.4.0
+ dev-util/intltool
+ >=net-libs/libsoup-2.4.0
+ >=dev-libs/libxml2-2.0
+ app-text/talkfilters
+ dev-perl/XML-Parser"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/libtranslate-ds-timed24.patch || die
+ epatch "${FILESDIR}"/libtranslate-ds-memory.patch || die
+
+ epatch "${FILESDIR}"/libtranslate-0.99-charsetparse.diff || die
+ epatch "${FILESDIR}"/libtranslate-0.99-condfix.diff || die
+ epatch "${FILESDIR}"/libtranslate-ds-empty.patch || die
+ epatch "${FILESDIR}"/libtranslate-ds-promt.patch || die
+ epatch "${FILESDIR}"/libtranslate-ds-fixcharset.patch || die
+ epatch "${FILESDIR}"/libtranslate-soup24inc.patch || die
+}
+
+src_compile() {
+ rm -f Makefile.in aclocal.m4
+ aclocal -I m4 || die
+ intltoolize --force || die
+ libtoolize || die
+ automake --add-missing || die
+ autoconf || die
+ econf
+ emake
+}
+
+src_install() {
+# Installing new services.xml without broken items
+ cp -f ${FILESDIR}/services.xml data/
+
+ make install DESTDIR="${D}"
+
+ cd ${S}
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+}