summaryrefslogtreecommitdiffstats
path: root/app-admin/openshift-source-to-image/openshift-source-to-image-1.1.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/openshift-source-to-image/openshift-source-to-image-1.1.8.ebuild')
-rw-r--r--app-admin/openshift-source-to-image/openshift-source-to-image-1.1.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/openshift-source-to-image/openshift-source-to-image-1.1.8.ebuild b/app-admin/openshift-source-to-image/openshift-source-to-image-1.1.8.ebuild
new file mode 100644
index 0000000..8e21426
--- /dev/null
+++ b/app-admin/openshift-source-to-image/openshift-source-to-image-1.1.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Enterprise Kubernetes for Developers (Client Tools)"
+HOMEPAGE="https://www.openshift.org"
+SRC_URI="https://github.com/openshift/source-to-image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bash-completion"
+
+DEPEND="dev-lang/go"
+RDEPEND="bash-completion? ( >=app-shells/bash-completion-2.3-r1 )"
+
+S="${WORKDIR}/source-to-image-${PV}"
+
+src_compile() {
+ export S2I_GIT_CATALOG_VERSION="v${PV}"
+ export S2I_GIT_MINOR=""
+ export S2I_GIT_MAJOR=""
+ export S2I_GIT_VERSION="v${PV}"
+ hack/build-go.sh || die
+}
+
+src_install() {
+ case "${ARCH}" in
+ x86) MY_ARCH="386" ;;
+ *) MY_ARCH="${ARCH}" ;;
+ esac
+
+ dobin "_output/local/bin/linux/${MY_ARCH}/s2i"
+ dobin "_output/local/bin/linux/${MY_ARCH}/sti"
+ use bash-completion && dobashcomp contrib/completions/bash/s2i
+}