summaryrefslogtreecommitdiffstats
path: root/app-admin/ansible/ansible-2.4.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible/ansible-2.4.3.0-r1.ebuild')
-rw-r--r--app-admin/ansible/ansible-2.4.3.0-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-2.4.3.0-r1.ebuild b/app-admin/ansible/ansible-2.4.3.0-r1.ebuild
new file mode 100644
index 0000000..7861a53
--- /dev/null
+++ b/app-admin/ansible/ansible-2.4.3.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1 eutils versionator
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="http://ansible.com/"
+SRC_URI="http://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 x64-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+#SDS
+PATCHES=(
+ "${FILESDIR}"/${PN}-ds-gi.patch
+ "${FILESDIR}"/${PN}-ds-dns4.patch
+)
+#EDS
+
+# not included in release tarball
+RESTRICT="test"
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+}