summaryrefslogtreecommitdiffstats
path: root/sci-geosciences/gosmore/gosmore-9999.ebuild
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2019-09-01 00:00:32 +0200
committerSuren A. Chilingaryan <csa@suren.me>2019-09-01 00:00:32 +0200
commitca9627e70852f6b2e835660df870fe3ab405882d (patch)
tree0a008b1d5b16fa0679a195ed7b5662c7891f591c /sci-geosciences/gosmore/gosmore-9999.ebuild
downloaddarklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.gz
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.bz2
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.xz
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.zip
Initial import
Diffstat (limited to 'sci-geosciences/gosmore/gosmore-9999.ebuild')
-rw-r--r--sci-geosciences/gosmore/gosmore-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-geosciences/gosmore/gosmore-9999.ebuild b/sci-geosciences/gosmore/gosmore-9999.ebuild
new file mode 100644
index 0000000..66e8c3b
--- /dev/null
+++ b/sci-geosciences/gosmore/gosmore-9999.ebuild
@@ -0,0 +1,22 @@
+EAPI="1"
+inherit subversion
+
+DESCRIPTION="osmore is a routing and viewer of OSM XML data"
+HOMEPAGE="http://wiki.openstreetmap.org/wiki/Gosmore"
+SRC_URI=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+
+ESVN_REPO_URI="http://svn.openstreetmap.org/applications/rendering/gosmore/"
+
+src_compile() {
+ perl -pi -e "s|\(prefix\)/usr/share/|(prefix)/share/gosmore/|g" Makefile || die
+
+ emake prefix=/usr
+}
+
+src_install () {
+ emake install DESTDIR="${D}" prefix=/usr
+}