summaryrefslogtreecommitdiffstats
path: root/dev-ruby/gli/gli-2.19.0.ebuild
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2019-10-24 02:09:32 +0200
committerSuren A. Chilingaryan <csa@suren.me>2019-10-24 02:09:32 +0200
commitdd2aea324c07fe1bd13143bb37eff11117b6130a (patch)
tree771ed8c8b9b1eb2f02b5843363eed86839ed6e5a /dev-ruby/gli/gli-2.19.0.ebuild
parent576b6208d6defe240bfa2477d6dd19f1ed83bfaf (diff)
downloaddarklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.tar.gz
darklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.tar.bz2
darklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.tar.xz
darklin4-dd2aea324c07fe1bd13143bb37eff11117b6130a.zip
Dice(kiwi) and dependencies; kiwi and dependecies (still missing zypper)
Diffstat (limited to 'dev-ruby/gli/gli-2.19.0.ebuild')
-rw-r--r--dev-ruby/gli/gli-2.19.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/gli/gli-2.19.0.ebuild b/dev-ruby/gli/gli-2.19.0.ebuild
new file mode 100644
index 0000000..cf3eab3
--- /dev/null
+++ b/dev-ruby/gli/gli-2.19.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE="rake"
+RUBY_FAKEGEM_TASK_DOC="build_rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="gli.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Git-Like Interface Command Line Parser"
+HOMEPAGE="https://davetron5000.github.com/gli"
+LICENSE="Apache-2.0"
+
+KEYWORDS="x86 amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -e '/sdoc/ s:^:#:' -i Rakefile || die
+
+ sed -e 's:tmp/fakehome:#{ENV["TMPDIR"]}/fakehome:' -i features/support/env.rb || die
+}
+
+each_ruby_test() {
+ # Unit tests depend on unpackaged clean_test.
+ ${RUBY} -S cucumber --format progress features || die
+}