summaryrefslogtreecommitdiffstats
path: root/app-admin/vlogger/vlogger-1.3.ebuild
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2019-09-01 00:00:32 +0200
committerSuren A. Chilingaryan <csa@suren.me>2019-09-01 00:00:32 +0200
commitca9627e70852f6b2e835660df870fe3ab405882d (patch)
tree0a008b1d5b16fa0679a195ed7b5662c7891f591c /app-admin/vlogger/vlogger-1.3.ebuild
downloaddarklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.gz
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.bz2
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.tar.xz
darklin4-ca9627e70852f6b2e835660df870fe3ab405882d.zip
Initial import
Diffstat (limited to 'app-admin/vlogger/vlogger-1.3.ebuild')
-rw-r--r--app-admin/vlogger/vlogger-1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/vlogger/vlogger-1.3.ebuild b/app-admin/vlogger/vlogger-1.3.ebuild
new file mode 100644
index 0000000..63433ee
--- /dev/null
+++ b/app-admin/vlogger/vlogger-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Virtual web logfile rotater/parser, similar to cronolog and httplog"
+HOMEPAGE="http://n0rp.chemlab.org/vlogger/"
+SRC_URI="http://n0rp.chemlab.org/vlogger/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE="dbi"
+
+DEPEND=""
+RDEPEND="dev-perl/TimeDate
+ dbi? ( dev-perl/DBI )"
+
+src_install() {
+ doman vlogger.1
+ dodoc README
+ insinto /etc/vlogger
+ dobin vlogger
+ if use dbi ; then
+ doins vlogger-dbi.conf
+ dodoc mysql_create.sql
+ fi
+}
+
+pkg_postinst() {
+ if use dbi ; then
+ elog "If you wish to use vlogger with DBI please see /etc/vlogger/vlogger-dbi.conf"
+ elog "The SQL to create the tables for DBI can be found in /usr/share/doc/${P}"
+ fi
+}