summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2016-02-04 02:46:51 +0100
committerSuren A. Chilingaryan <csa@suren.me>2016-02-04 02:46:51 +0100
commitab0797327e5b7cf4c4710ce7d2fff533ba405507 (patch)
tree2fdcd103b49d00521043b83898c2f7e666b6f84f /CMakeLists.txt
parent4f5185b37980bdf962ff7058e9f8fbb06098386c (diff)
downloadpcitool-ab0797327e5b7cf4c4710ce7d2fff533ba405507.tar.gz
pcitool-ab0797327e5b7cf4c4710ce7d2fff533ba405507.tar.bz2
pcitool-ab0797327e5b7cf4c4710ce7d2fff533ba405507.tar.xz
pcitool-ab0797327e5b7cf4c4710ce7d2fff533ba405507.zip
Fix build system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46a35b3..fcd82b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,8 +64,8 @@ VERSION_TO_VARS(${PCILIB_VERSION} PCILIB_VERSION_MAJOR PCILIB_VERSION_MINOR PCIL
add_custom_target(build)
add_custom_command(TARGET build
- COMMAND ${CMAKE_COMMAND} -P ${CMAKE_SOURCE_DIR}/cmake/build.cmake
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+ COMMAND ${CMAKE_COMMAND} -DPCILIB_SOURCE_DIR=${CMAKE_SOURCE_DIR} -DPCILIB_BINARY_DIR=${CMAKE_BINARY_DIR} -P ${CMAKE_SOURCE_DIR}/cmake/build.cmake
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
)
set_source_files_properties(${CMAKE_BINARY_DIR}/pcilib/build.h PROPERTIES GENERATED TRUE)