summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6d683e..66d5cbc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,7 @@ set(FASTWRITER_ABI_VERSION "0")
cmake_minimum_required(VERSION 2.8)
set(DISABLE_XFS_REALTIME FALSE CACHE BOOL "Disable support of RealTime XFS partition")
-
+set(USE_CUSTOM_MEMCPY FALSE CACHE BOOL "Use custom memcpy routine instead of stanadrd")
include(CheckIncludeFiles)
check_include_files("linux/falloc.h" HAVE_LINUX_FALLOC_H)
@@ -25,8 +25,14 @@ include_directories(
add_definitions("-fPIC --std=c99 -Wall -O2 -pthread")
-set(HEADERS fastwriter.h sysinfo.h default.h private.h)
-add_library(fastwriter SHARED fastwriter.c sysinfo.c default.c memcpy.c)
+if (USE_CUSTOM_MEMCPY)
+ set(HEADERS fastwriter.h sysinfo.h default.h private.h memcpy.h)
+ add_library(fastwriter SHARED fastwriter.c sysinfo.c default.c memcpy.c)
+else (USE_CUSTOM_MEMCPY)
+ set(HEADERS fastwriter.h sysinfo.h default.h private.h)
+ add_library(fastwriter SHARED fastwriter.c sysinfo.c default.c)
+endif (USE_CUSTOM_MEMCPY)
+
set_target_properties(fastwriter PROPERTIES
VERSION ${FASTWRITER_VERSION}