summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a95a93..496864e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,7 @@ set(FASTWRITER_ABI_VERSION "0")
cmake_minimum_required(VERSION 2.8)
+set(DISABLE_AIO TRUE CACHE BOOL "Use kernel AIO writer")
set(DISABLE_XFS_REALTIME FALSE CACHE BOOL "Disable support of RealTime XFS partition")
@@ -26,7 +27,16 @@ include_directories(
add_definitions("-fPIC --std=c99 -Wall -O2 -pthread")
set(HEADERS fastwriter.h sysinfo.h default.h private.h)
-add_library(fastwriter SHARED fastwriter.c sysinfo.c default.c)
+set(SOURCES fastwriter.c sysinfo.c default.c)
+
+if (NOT DISABLE_AIO)
+ check_include_files("libaio.h" HAVE_LIBAIO_H)
+ if (NOT HAVE_LIBAIO_H)
+ message(FATAL_ERROR "error: libaio.h is not found...")
+ endif (NOT HAVE_LIBAIO_H)
+endif (NOT DISABLE_AIO)
+
+add_library(fastwriter SHARED ${SOURCES})
set_target_properties(fastwriter PROPERTIES
VERSION ${FASTWRITER_VERSION}
@@ -34,6 +44,11 @@ set_target_properties(fastwriter PROPERTIES
LINK_FLAGS "-pthread"
)
+if (NOT DISABLE_AIO)
+ target_link_libraries(fastwriter aio)
+endif (NOT DISABLE_AIO)
+
+
set(TARNAME "fastwriter")
set(PACKAGE_VERSION ${FASTWRITER_VERSION})
set(PACKAGE_NAME "${TARNAME}")