summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2012-03-08 21:26:06 +0100
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2012-03-08 21:26:06 +0100
commit4fdf54d4690fdf33c94b27bcf44094bb933e11fd (patch)
treea18e4b509f30e95c48df4641a823190cf1210f53 /CMakeLists.txt
parent792cb8124ebb8f119f678d5d4df1a8d30d568564 (diff)
downloadfastwriter-4fdf54d4690fdf33c94b27bcf44094bb933e11fd.tar.gz
fastwriter-4fdf54d4690fdf33c94b27bcf44094bb933e11fd.tar.bz2
fastwriter-4fdf54d4690fdf33c94b27bcf44094bb933e11fd.tar.xz
fastwriter-4fdf54d4690fdf33c94b27bcf44094bb933e11fd.zip
Support XFS RealTime partition
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94d1ad8..7cc39b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,14 +1,23 @@
project(fastwriter)
-set(FASTWRITER_VERSION "0.0.1")
+set(FASTWRITER_VERSION "0.0.2")
set(FASTWRITER_ABI_VERSION "0")
cmake_minimum_required(VERSION 2.8)
+set(DISABLE_XFS_REALTIME FALSE CACHE BOOL "Disable support of RealTime XFS partition")
+
include(CheckIncludeFiles)
check_include_files("linux/falloc.h" HAVE_LINUX_FALLOC_H)
+if (NOT DISABLE_XFS_REALTIME)
+ check_include_files("xfs/xfs.h" HAVE_XFS_H)
+ if (NOT HAVE_XFS_H)
+ message(FATAL_ERROR "error: xfs/xfs.h is not found...")
+ endif (NOT HAVE_XFS_H)
+endif (NOT DISABLE_XFS_REALTIME)
+
include_directories(
${CMAKE_SOURCE_DIR}/src
${CMAKE_CURRENT_BINARY_DIR}