summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2012-12-03 22:13:51 +0100
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2012-12-03 22:13:51 +0100
commit382ba1a1630cb1647c8e5ed3feb37364a8f3329f (patch)
treee430a07890c42f48159a3be3b56b3cc94b93f900 /CMakeLists.txt
parent5ae22aeedb43629fed30f64d025b9df3cf25cff8 (diff)
parent83ebc0af67cf2d4cd5a45fa253dac88f1cb3b1e4 (diff)
downloadfastwriter-382ba1a1630cb1647c8e5ed3feb37364a8f3329f.tar.gz
fastwriter-382ba1a1630cb1647c8e5ed3feb37364a8f3329f.tar.bz2
fastwriter-382ba1a1630cb1647c8e5ed3feb37364a8f3329f.tar.xz
fastwriter-382ba1a1630cb1647c8e5ed3feb37364a8f3329f.zip
Merge custom memcpy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 496864e..19fa71c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ cmake_minimum_required(VERSION 2.8)
set(DISABLE_AIO TRUE CACHE BOOL "Use kernel AIO writer")
set(DISABLE_XFS_REALTIME FALSE CACHE BOOL "Disable support of RealTime XFS partition")
-
+set(USE_CUSTOM_MEMCPY FALSE CACHE BOOL "Use custom memcpy routine instead of stanadrd")
include(CheckIncludeFiles)
check_include_files("linux/falloc.h" HAVE_LINUX_FALLOC_H)
@@ -29,6 +29,11 @@ add_definitions("-fPIC --std=c99 -Wall -O2 -pthread")
set(HEADERS fastwriter.h sysinfo.h default.h private.h)
set(SOURCES fastwriter.c sysinfo.c default.c)
+if (USE_CUSTOM_MEMCPY)
+ set(HEADERS ${HEADERS} memcpy.h)
+ set(SOURCES ${SOURCES} memcpy.c)
+endif (USE_CUSTOM_MEMCPY)
+
if (NOT DISABLE_AIO)
check_include_files("libaio.h" HAVE_LIBAIO_H)
if (NOT HAVE_LIBAIO_H)
@@ -48,7 +53,6 @@ if (NOT DISABLE_AIO)
target_link_libraries(fastwriter aio)
endif (NOT DISABLE_AIO)
-
set(TARNAME "fastwriter")
set(PACKAGE_VERSION ${FASTWRITER_VERSION})
set(PACKAGE_NAME "${TARNAME}")