summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorroot <root@ipepdvdev1.ipe.kit.edu>2015-05-05 16:00:12 +0200
committerroot <root@ipepdvdev1.ipe.kit.edu>2015-05-05 16:00:12 +0200
commit9c49ca07021cea3f923b39d70b3580970963d0ec (patch)
treee19d273f12ed47ae0f8f0120a11fe86ecb19cbf5 /CMakeLists.txt
downloadipedma_test-9c49ca07021cea3f923b39d70b3580970963d0ec.tar.gz
ipedma_test-9c49ca07021cea3f923b39d70b3580970963d0ec.tar.bz2
ipedma_test-9c49ca07021cea3f923b39d70b3580970963d0ec.tar.xz
ipedma_test-9c49ca07021cea3f923b39d70b3580970963d0ec.zip
Initial import
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..eb1b766
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,28 @@
+project(ipedma_test)
+
+cmake_minimum_required(VERSION 2.6)
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(PCILIB pcitool>=0.2 REQUIRED)
+
+
+include_directories(
+ ${PCILIB_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${PCILIB_LIBRARY_DIRS}
+)
+
+add_executable(ipedma_test ipedma_test.c)
+target_link_libraries(ipedma_test ${PCILIB_LIBRARIES})
+set_target_properties(ipedma_test PROPERTIES COMPILE_FLAGS -Wno-array-bounds)
+
+add_executable(check_counter check_counter.c)
+
+
+if(NOT DEFINED BIN_INSTALL_DIR)
+ set(BIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/bin")
+endif(NOT DEFINED BIN_INSTALL_DIR)
+
+install(TARGETS ipedma_test check_counter DESTINATION ${BIN_INSTALL_DIR})