summaryrefslogtreecommitdiffstats
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index eb981b2..4cd4bdc 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -48,7 +48,6 @@ plugins = [
'merge',
'metaballs',
'monitor',
- 'non-local-means',
'null',
'opencl',
'opencl-reduce',
@@ -171,6 +170,20 @@ shared_module('conebeamprojectionweight',
install_dir: plugin_install_dir,
)
+# non local means
+
+shared_module('nonlocalmeans',
+ sources: [
+ 'ufo-non-local-means-task.c',
+ 'common/ufo-math.c',
+ 'common/ufo-common.c',
+ ],
+ dependencies: deps,
+ name_prefix: 'libufofilter',
+ install: true,
+ install_dir: plugin_install_dir,
+)
+
# fft plugins
have_clfft = clfft_dep.found()