summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29c40af..a10c2e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,9 +45,11 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/deps/oclfft)
link_directories(${UFO_LIBRARY_DIRS})
#}}}
#{{{ Global definitions
-add_definitions("-std=c99 -pedantic -Wall -Wextra -fPIC")
+add_definitions("-pedantic -Wall -Wextra -fPIC")
add_definitions(-DG_LOG_DOMAIN="Ufo")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")
+
if (CMAKE_COMPILER_IS_GNUCC OR ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang"))
add_definitions("-Wno-unused-parameter")
endif ()