summaryrefslogtreecommitdiffstats
path: root/contrib/meson.build
diff options
context:
space:
mode:
authorTomas Farago <sensej007@email.cz>2020-06-12 14:07:01 +0200
committerTomas Farago <sensej007@email.cz>2020-06-12 14:07:01 +0200
commit86c9551f08a28db25ff4966093114a92eb92f6bb (patch)
tree7d1560c06e42eaa54f4072168351dc186a4528cd /contrib/meson.build
parentdb3cd886b8303a8a5aff20c76660ed49c2365f94 (diff)
downloadufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.tar.gz
ufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.tar.bz2
ufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.tar.xz
ufo-filters-86c9551f08a28db25ff4966093114a92eb92f6bb.zip
Fix undefined CL_TARGET_OPENCL_VERSION warning
This is hardcoded to 120 (= OpenCL 1.2) because nvidia does not support later standards until 3.0 comes around and we do not make use of later features anyway.
Diffstat (limited to 'contrib/meson.build')
-rw-r--r--contrib/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/contrib/meson.build b/contrib/meson.build
index 747d2be..80da0db 100644
--- a/contrib/meson.build
+++ b/contrib/meson.build
@@ -27,3 +27,11 @@ endforeach
install_data(kernels,
install_dir: kernel_install_dir,
)
+
+conf = configuration_data()
+conf.set('CL_TARGET_OPENCL_VERSION', '120')
+configure_file(
+ input: 'config.h.meson.in',
+ output: 'config.h',
+ configuration: conf,
+)