summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-19 14:12:25 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2012-03-19 14:12:25 +0100
commite14fa8cd9462344d8e9527dc5ef6c74b19734c6f (patch)
tree3689b4dfa2a50f3d6663149fb50deed33c054e12 /CMakeLists.txt
parent769b2ff8efc2fa618c82bedfbea3e7aa2b961c0d (diff)
downloadufo-filters-e14fa8cd9462344d8e9527dc5ef6c74b19734c6f.tar.gz
ufo-filters-e14fa8cd9462344d8e9527dc5ef6c74b19734c6f.tar.bz2
ufo-filters-e14fa8cd9462344d8e9527dc5ef6c74b19734c6f.tar.xz
ufo-filters-e14fa8cd9462344d8e9527dc5ef6c74b19734c6f.zip
Enable all warnings
If there wasn't OpenCV we could also enable -Werror but this nice piece of software is giving tons of warnings which would then break building the filters...
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8653bf..89e0982 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,7 +33,15 @@ include_directories(
${UFO_INCLUDE_DIRS}
)
-add_definitions("-std=c99 -Wall -fPIC")
+add_definitions("-std=c99 -pedantic -Wall -Wextra -fPIC")
+if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions("-Wmissing-prototypes -Wmissing-declarations -Wshadow
+ -Wpointer-arith -Wcast-align -Wwrite-strings -Wredundant-decls -Wcast-qual
+ -Wnested-externs -Winline -Wno-long-long -Wconversion -Wstrict-prototypes")
+
+ add_definitions("-Wno-unused-parameter -Wno-missing-field-initializers")
+endif()
+
add_definitions(-DG_LOG_DOMAIN="Ufo")
add_subdirectory(src)