summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-10-13 11:43:53 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-10-13 14:35:18 +0200
commitb4a28118497b05e3368667863f24146fd4bf3146 (patch)
treeb545aa04fcf01b277cd4541441eb26b1e2f1ede4 /CMakeLists.txt
parent772ed6e8b87fe7fd6d2fbe4e0ce3e886ae27a6c1 (diff)
downloadufo-filters-b4a28118497b05e3368667863f24146fd4bf3146.tar.gz
ufo-filters-b4a28118497b05e3368667863f24146fd4bf3146.tar.bz2
ufo-filters-b4a28118497b05e3368667863f24146fd4bf3146.tar.xz
ufo-filters-b4a28118497b05e3368667863f24146fd4bf3146.zip
Add tests and execute them with TravisCI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0632ef9..e508da4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,9 +73,12 @@ if (CMAKE_COMPILER_IS_GNUCC OR ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang"))
endif ()
#}}}
#{{{ Subdirectories
+enable_testing()
+
add_subdirectory(docs)
add_subdirectory(deps)
add_subdirectory(src)
+add_subdirectory(tests)
if (WITH_CONTRIB)
add_subdirectory(contrib)
endif ()