summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSerge Cohen <serge@chocolatnoir.net>2017-01-15 01:40:55 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-01-17 09:39:27 +0100
commita82a4551066142cb23ae8179c2bd139d818e9cc8 (patch)
tree9e18f3cf05238ffc1f16d2929674ac4705b3910e /CMakeLists.txt
parent0eeca3e2d83a1226d8d3a4f3db57a14876ac4ad3 (diff)
downloadufo-filters-a82a4551066142cb23ae8179c2bd139d818e9cc8.tar.gz
ufo-filters-a82a4551066142cb23ae8179c2bd139d818e9cc8.tar.bz2
ufo-filters-a82a4551066142cb23ae8179c2bd139d818e9cc8.tar.xz
ufo-filters-a82a4551066142cb23ae8179c2bd139d818e9cc8.zip
Fixup for compilation and installation on MacOS
Avoids the need for DYLD_LIBRARY_PATH, which anyway is not accepted anymore since 10.10 or 10.11.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c62699..567a543 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,11 @@ set(UFO_DESCRIPTION_SUMMARY "UFO good filters")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/common/cmake")
+if (APPLE)
+ set(CMAKE_MACOSX_RPATH "ON")
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+endif()
+
#{{{ Variables and Options
include(GNUInstallDirs)
include(PkgConfigVars)