summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@ipe.fzk.de>2011-02-09 17:36:55 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@ipe.fzk.de>2011-02-09 17:36:55 +0100
commit601ffc2f442cd85505bd67c8dcf8493423e4da4a (patch)
treebbd65eaaf94d61915986c688269cf5de67bb6efb /CMakeLists.txt
parent3d962eaa7186d9399fffd2c3b6636f5910ca31a6 (diff)
downloadufo-filters-601ffc2f442cd85505bd67c8dcf8493423e4da4a.tar.gz
ufo-filters-601ffc2f442cd85505bd67c8dcf8493423e4da4a.tar.bz2
ufo-filters-601ffc2f442cd85505bd67c8dcf8493423e4da4a.tar.xz
ufo-filters-601ffc2f442cd85505bd67c8dcf8493423e4da4a.zip
Add support for Debian .deb generation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58515a8..bef6dc4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,3 +7,13 @@ add_subdirectory(ufo-core)
add_subdirectory(ufo-tools)
add_subdirectory(ufo-bindings)
add_subdirectory(thirdparty)
+
+# --- Generate packages -------------------------------------------------------
+
+set(CPACK_GENERATOR "DEB")
+set(CPACK_DEBIAN_PACKAGE_MAINTAINER "Matthias Vogelgesang <matthias.vogelgesang@ipe.fzk.de>")
+set(CPACK_DEBIAN_PACKAGE_DESCRIPTION "Core libraries and tools of the UFO project")
+set(CPACK_DEBIAN_PACKAGE_DESCRIPTION_SUMMARY "Core libraries and tools of the UFO project")
+set(CPACK_DEBIAN_PACKAGE_VERSION "0.0.1")
+
+include(CPack)