summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSerge Cohen <serge@chocolatnoir.net>2017-01-04 23:17:00 +0100
committerMatthias Vogelgesang <matthias.vogelgesang@kit.edu>2017-01-10 15:43:52 +0100
commit20e0efa57c172521397438bcf30081f2a1577019 (patch)
treefa6c4fa2afe2de1735311875a47fa1e960d5ed76 /CMakeLists.txt
parent0e3cca9cb63656c88bb336de42c54bfadc16d827 (diff)
downloadufo-filters-20e0efa57c172521397438bcf30081f2a1577019.tar.gz
ufo-filters-20e0efa57c172521397438bcf30081f2a1577019.tar.bz2
ufo-filters-20e0efa57c172521397438bcf30081f2a1577019.tar.xz
ufo-filters-20e0efa57c172521397438bcf30081f2a1577019.zip
Include limited contrib/ directory
Cmake integration included a first contributed filter(s), building contrib requires the CMake option : -DWITH_CONTRIBS:BOOL=ON (this one is OFF by default). Added 4 new contributed filters : * Median-MAD rejection in 3D 3x3x3 box size * Median-MAD rejection in 2D but variable box size * OpenCL 1-liner and multi-input filter * Monitoring statistics of an image stream (min, max, mean, var)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15bd539..367fb83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,4 +69,7 @@ endif ()
add_subdirectory(docs)
add_subdirectory(deps)
add_subdirectory(src)
+if ("${WITH_CONTRIBS}")
+ add_subdirectory(contribs)
+endif ()
#}}}