summaryrefslogtreecommitdiffstats
path: root/utils/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'utils/setup.cfg')
-rw-r--r--utils/setup.cfg13
1 files changed, 13 insertions, 0 deletions
diff --git a/utils/setup.cfg b/utils/setup.cfg
index 79bc67848..f5f0d8aad 100644
--- a/utils/setup.cfg
+++ b/utils/setup.cfg
@@ -3,3 +3,16 @@
# 3. If at all possible, it is good practice to do this. If you cannot, you
# will need to generate wheels for each Python version that you support.
universal=1
+
+[nosetests]
+tests=../,../roles/openshift_master_facts/test/,test/
+verbosity=2
+with_coverage=1
+cover_html=1
+cover_package=ooinstall
+cover_min_percentage=70
+
+[flake8]
+max-line-length=120
+exclude=tests/*,setup.py
+ignore=E501,E121,E124