summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 05a23b7bb..c826c167f 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,7 @@ from yamllint.config import YamlLintConfig
from yamllint.cli import Format
from yamllint import linter
+
def find_files(base_dir, exclude_dirs, include_dirs, file_regex):
''' find files matching file_regex '''
found = []
@@ -111,7 +112,8 @@ class OpenShiftAnsibleYamlLint(Command):
if has_errors or has_warnings:
print('yammlint issues found')
- exit(1)
+ raise SystemExit(1)
+
class OpenShiftAnsiblePylint(PylintCommand):
''' Class to override the default behavior of PylintCommand '''