summaryrefslogtreecommitdiffstats
path: root/openshift-ansible.spec
diff options
context:
space:
mode:
Diffstat (limited to 'openshift-ansible.spec')
-rw-r--r--openshift-ansible.spec33
1 files changed, 33 insertions, 0 deletions
diff --git a/openshift-ansible.spec b/openshift-ansible.spec
index 0c754a7b9..a24ca0c8a 100644
--- a/openshift-ansible.spec
+++ b/openshift-ansible.spec
@@ -26,6 +26,10 @@ for Openshift and Atomic Enterprise.
%build
+# atomic-openshift-utils install
+pushd utils
+%{__python} setup.py build
+popd
%install
# Base openshift-ansible install
@@ -73,6 +77,13 @@ cp -rp filter_plugins %{buildroot}%{_datadir}/ansible_plugins/
# openshift-ansible-lookup-plugins install
cp -rp lookup_plugins %{buildroot}%{_datadir}/ansible_plugins/
+# atomic-openshift-utils install
+pushd utils
+%{__python} setup.py install --skip-build --root %{buildroot}
+# Remove this line once the name change has happened
+mv -f %{buildroot}%{_bindir}/oo-install %{buildroot}%{_bindir}/atomic-openshift-installer
+popd
+
# Base openshift-ansible files
%files
%doc LICENSE.md README*
@@ -190,6 +201,28 @@ BuildArch: noarch
%files lookup-plugins
%{_datadir}/ansible_plugins/lookup_plugins
+# ----------------------------------------------------------------------------------
+# atomic-openshift-utils subpackage
+# ----------------------------------------------------------------------------------
+
+%package -n atomic-openshift-utils
+Summary: Atomic OpenShift Utilities
+BuildRequires: python-setuptools
+Requires: ansible
+Requires: python-click
+Requires: python-setuptools
+Requires: PyYAML
+BuildArch: noarch
+
+%description -n atomic-openshift-utils
+Atomic OpenShift Utilities includes
+ - atomic-openshift-installer
+ - other utilities
+
+%files -n atomic-openshift-utils
+%{python_sitelib}/ooinstall*
+%{_bindir}/atomic-openshift-installer
+
%changelog
* Mon Oct 19 2015 Troy Dawson <tdawson@redhat.com> 3.0.2-1