summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Gugino <mgugino@redhat.com>2017-12-21 12:09:17 -0500
committerMichael Gugino <mgugino@redhat.com>2017-12-21 13:17:53 -0500
commit3a14ee697aafa52d94ce577c16378c5fe18dda06 (patch)
tree22f08f765c3ef8fb3b07bd1c6be817986c794376 /setup.py
parentcbcfd8a6d669e5b76afca79d3523bc537df804d3 (diff)
downloadopenshift-3a14ee697aafa52d94ce577c16378c5fe18dda06.tar.gz
openshift-3a14ee697aafa52d94ce577c16378c5fe18dda06.tar.bz2
openshift-3a14ee697aafa52d94ce577c16378c5fe18dda06.tar.xz
openshift-3a14ee697aafa52d94ce577c16378c5fe18dda06.zip
Fix container_runtime openshift_containerized_host_groups
openshift_containerized_host_groups needs to be referenced via hostvars. This commit also updates tox ansible syntax checks to account for unavailability of hostsvars during syntax checks. Fixes: https://github.com/openshift/openshift-ansible/issues/6540
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 3 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 5ba050b83..f6b494858 100644
--- a/setup.py
+++ b/setup.py
@@ -348,21 +348,10 @@ class OpenShiftAnsibleSyntaxCheck(Command):
# --syntax-check each entry point playbook
try:
# Create a host group list to avoid WARNING on unmatched host patterns
- host_group_list = [
- 'etcd,masters,nodes,OSEv3',
- 'oo_all_hosts',
- 'oo_etcd_to_config,oo_new_etcd_to_config,oo_first_etcd,oo_etcd_hosts_to_backup,'
- 'oo_etcd_hosts_to_upgrade,oo_etcd_to_migrate',
- 'oo_masters,oo_masters_to_config,oo_first_master,oo_containerized_master_nodes',
- 'oo_nodes_to_config,oo_nodes_to_upgrade',
- 'oo_nodes_use_kuryr,oo_nodes_use_flannel',
- 'oo_nodes_use_calico,oo_nodes_use_nuage,oo_nodes_use_contiv',
- 'oo_lb_to_config',
- 'oo_nfs_to_config',
- 'glusterfs,glusterfs_registry,']
+ tox_ansible_inv = os.environ['TOX_ANSIBLE_INV_PATH']
subprocess.check_output(
- ['ansible-playbook', '-i ' + ','.join(host_group_list),
- '--syntax-check', playbook]
+ ['ansible-playbook', '-i', tox_ansible_inv,
+ '--syntax-check', playbook, '-e', '@{}_extras'.format(tox_ansible_inv)]
)
except subprocess.CalledProcessError as cpe:
print('{}Execution failed: {}{}'.format(