summaryrefslogtreecommitdiffstats
path: root/openshift-ansible.spec
diff options
context:
space:
mode:
authorScott Dodson <sdodson@redhat.com>2018-01-05 12:44:56 -0500
committerScott Dodson <sdodson@redhat.com>2018-01-05 12:44:56 -0500
commiteacc12897ca86a255f89b8a4537ce2b7004cf319 (patch)
tree6ea69dfb326cdb5b726d5f414f6d9a509db77875 /openshift-ansible.spec
parent9f19afc7529bd7293433b27e834b9ee3479e646f (diff)
downloadopenshift-eacc12897ca86a255f89b8a4537ce2b7004cf319.tar.gz
openshift-eacc12897ca86a255f89b8a4537ce2b7004cf319.tar.bz2
openshift-eacc12897ca86a255f89b8a4537ce2b7004cf319.tar.xz
openshift-eacc12897ca86a255f89b8a4537ce2b7004cf319.zip
Migrate to import_role for static role inclusion
In Ansible 2.2, the include_role directive came into existence as a Tech Preview. It is still a Tech Preview through Ansible 2.4 (and in current devel branch), but with a noteable change. The default behavior switched from static: true to static: false because that functionality moved to the newly introduced import_role directive (in order to stay consistent with include* being dynamic in nature and `import* being static in nature). The dynamic include is considerably more memory intensive as it will dynamically create a role import for every host in the inventory list to be used. (Also worth noting, there is at the time of this writing an object allocation inefficiency in the dynamic include that can in certain situations amplify this effect considerably) This change is meant to mitigate the pressure on memory for the Ansible control host. We need to evaluate where it makes sense to dynamically include roles and revert back to dynamic inclusion if and where it makes sense to do so.
Diffstat (limited to 'openshift-ansible.spec')
-rw-r--r--openshift-ansible.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/openshift-ansible.spec b/openshift-ansible.spec
index 80b5c23d0..06f5d3669 100644
--- a/openshift-ansible.spec
+++ b/openshift-ansible.spec
@@ -408,7 +408,7 @@ Atomic OpenShift Utilities includes
- Update prometheus to 2.0.0 GA (zgalor@redhat.com)
- remove schedulable from openshift_facts (mgugino@redhat.com)
- inventory: Add example for service catalog vars (smilner@redhat.com)
-- Correct usage of include_role (rteague@redhat.com)
+- Correct usage of import_role (rteague@redhat.com)
- Remove openshift.common.cli_image (mgugino@redhat.com)
- Fix openshift_env fact creation within openshift_facts. (abutcher@redhat.com)
- Combine openshift_node and openshift_node_dnsmasq (mgugino@redhat.com)
@@ -1001,7 +1001,7 @@ Atomic OpenShift Utilities includes
- Renaming csr to bootstrap for consistency. (kwoodson@redhat.com)
- Add master config upgrade hook to upgrade-all plays (mgugino@redhat.com)
- Remove 'Not Started' status from playbook checkpoint (rteague@redhat.com)
-- Force include_role to static for loading openshift_facts module
+- Force import_role to static for loading openshift_facts module
(rteague@redhat.com)
- Make openshift-ansible depend on all subpackages (sdodson@redhat.com)
- Refactor health check playbooks (rteague@redhat.com)
@@ -3729,9 +3729,9 @@ Atomic OpenShift Utilities includes
- run node upgrade if master is node as part of the control plan upgrade only
(jchaloup@redhat.com)
- Appease yamllint (sdodson@redhat.com)
-- Adding include_role to block to resolve when eval (ewolinet@redhat.com)
+- Adding import_role to block to resolve when eval (ewolinet@redhat.com)
- Updating oc_apply to use command instead of shell (ewolinet@redhat.com)
-- Wrap openshift_hosted_logging include_role within a block.
+- Wrap openshift_hosted_logging import_role within a block.
(abutcher@redhat.com)
- Adding unit test. Fixed redudant calls to get. (kwoodson@redhat.com)
- Fixing doc and generating new label with updated base. (kwoodson@redhat.com)