summaryrefslogtreecommitdiffstats
path: root/openshift-ansible.spec
diff options
context:
space:
mode:
authorMatt Woodson <mwoodson@redhat.com>2017-03-29 10:07:29 -0400
committerMatt Woodson <mwoodson@redhat.com>2017-03-29 10:07:29 -0400
commitdbb9361bb780ed124decca33e447495a6fd7f9dd (patch)
tree4c4a52eb9a5deb6ee4f10315c5b7a17953a40c79 /openshift-ansible.spec
parent403b5c5545b9b07e7a4416e5a63609512ddaa224 (diff)
downloadopenshift-dbb9361bb780ed124decca33e447495a6fd7f9dd.tar.gz
openshift-dbb9361bb780ed124decca33e447495a6fd7f9dd.tar.bz2
openshift-dbb9361bb780ed124decca33e447495a6fd7f9dd.tar.xz
openshift-dbb9361bb780ed124decca33e447495a6fd7f9dd.zip
added a empty file to the contiv empty dir. This allows contiv to be vendored in git
Diffstat (limited to 'openshift-ansible.spec')
-rw-r--r--openshift-ansible.spec3
1 files changed, 3 insertions, 0 deletions
diff --git a/openshift-ansible.spec b/openshift-ansible.spec
index e0cd9c097..1e899cf18 100644
--- a/openshift-ansible.spec
+++ b/openshift-ansible.spec
@@ -76,6 +76,9 @@ find -L %{buildroot}%{_datadir}/ansible/%{name}/playbooks -name filter_plugins -
cp -rp roles %{buildroot}%{_datadir}/ansible/%{name}/
# remove contiv role
rm -rf %{buildroot}%{_datadir}/ansible/%{name}/roles/contiv/*
+# touch a file in contiv so that it can be added to SCM's
+touch %{buildroot}%{_datadir}/ansible/%{name}/roles/contiv/.empty_dir
+
# openshift_master_facts symlinks filter_plugins/oo_filters.py from ansible_plugins/filter_plugins
pushd %{buildroot}%{_datadir}/ansible/%{name}/roles/openshift_master_facts/filter_plugins
ln -sf ../../../../../ansible_plugins/filter_plugins/oo_filters.py oo_filters.py