summaryrefslogtreecommitdiffstats
path: root/openshift-ansible.spec
diff options
context:
space:
mode:
authorTroy Dawson <tdawson@redhat.com>2015-11-02 11:12:30 -0600
committerTroy Dawson <tdawson@redhat.com>2015-11-02 11:12:30 -0600
commit6c51d3181a003e99fba48bdfdb016d7b4a0bb8c0 (patch)
treed7a5c2a688a8b568c0e21f58779f931cf12d5d20 /openshift-ansible.spec
parent9e586db2931863780ce6598bb64b3a134c2fdb27 (diff)
downloadopenshift-6c51d3181a003e99fba48bdfdb016d7b4a0bb8c0.tar.gz
openshift-6c51d3181a003e99fba48bdfdb016d7b4a0bb8c0.tar.bz2
openshift-6c51d3181a003e99fba48bdfdb016d7b4a0bb8c0.tar.xz
openshift-6c51d3181a003e99fba48bdfdb016d7b4a0bb8c0.zip
split inventory into subpackages
Diffstat (limited to 'openshift-ansible.spec')
-rw-r--r--openshift-ansible.spec24
1 files changed, 23 insertions, 1 deletions
diff --git a/openshift-ansible.spec b/openshift-ansible.spec
index b905edaf8..8d79c80c6 100644
--- a/openshift-ansible.spec
+++ b/openshift-ansible.spec
@@ -128,7 +128,7 @@ BuildArch: noarch
# ----------------------------------------------------------------------------------
%package inventory
Summary: Openshift and Atomic Enterprise Ansible Inventories
-Requires: python2, python-boto, python-libcloud >= 0.13
+Requires: python2
BuildArch: noarch
%description inventory
@@ -138,7 +138,29 @@ Ansible Inventories used with the openshift-ansible scripts and playbooks.
%config(noreplace) /etc/ansible/*
%dir %{_datadir}/ansible/inventory
%{_datadir}/ansible/inventory/multi_ec2.py*
+
+%package inventory-aws
+Summary: Openshift and Atomic Enterprise Ansible Inventories for AWS
+Requires: %{name}-inventory
+Requires: python-boto
+BuildArch: noarch
+
+%description inventory-aws
+Ansible Inventories for AWS used with the openshift-ansible scripts and playbooks.
+
+%files inventory-aws
%{_datadir}/ansible/inventory/aws/ec2.py*
+
+%package inventory-gce
+Summary: Openshift and Atomic Enterprise Ansible Inventories for GCE
+Requires: %{name}-inventory
+Requires: python-libcloud >= 0.13
+BuildArch: noarch
+
+%description inventory-gce
+Ansible Inventories for GCE used with the openshift-ansible scripts and playbooks.
+
+%files inventory-gce
%{_datadir}/ansible/inventory/gce/gce.py*