summaryrefslogtreecommitdiffstats
path: root/inventory/openshift-ansible-inventory.spec
diff options
context:
space:
mode:
authorThomas Wiest <twiest@redhat.com>2015-03-25 16:45:50 -0400
committerThomas Wiest <twiest@redhat.com>2015-03-25 17:18:16 -0400
commitf79f6d649a4c8599121d9cad5492afc579f0425a (patch)
tree0d2680de10c529e631bcf77c7c1aea33e297ee1f /inventory/openshift-ansible-inventory.spec
parent08fbdf801ea69761d8337b17b0f2b5df07fdc5a1 (diff)
downloadopenshift-f79f6d649a4c8599121d9cad5492afc579f0425a.tar.gz
openshift-f79f6d649a4c8599121d9cad5492afc579f0425a.tar.bz2
openshift-f79f6d649a4c8599121d9cad5492afc579f0425a.tar.xz
openshift-f79f6d649a4c8599121d9cad5492afc579f0425a.zip
added the ability to have a config file in /etc/openshift_ansible to multi_ec2.py.
Diffstat (limited to 'inventory/openshift-ansible-inventory.spec')
-rw-r--r--inventory/openshift-ansible-inventory.spec6
1 files changed, 4 insertions, 2 deletions
diff --git a/inventory/openshift-ansible-inventory.spec b/inventory/openshift-ansible-inventory.spec
index e847df189..9b721818e 100644
--- a/inventory/openshift-ansible-inventory.spec
+++ b/inventory/openshift-ansible-inventory.spec
@@ -18,18 +18,20 @@ Ansible Inventories used with the openshift-ansible scripts and playbooks.
%build
%install
+mkdir -p %{buildroot}/etc/ansible
mkdir -p %{buildroot}/usr/share/ansible/inventory
mkdir -p %{buildroot}/usr/share/ansible/inventory/aws
mkdir -p %{buildroot}/usr/share/ansible/inventory/gce
-cp -p multi_ec2.py multi_ec2.yaml.example %{buildroot}/usr/share/ansible/inventory
+cp -p multi_ec2.py %{buildroot}/usr/share/ansible/inventory
+cp -p multi_ec2.yaml.example %{buildroot}/etc/ansible/multi_ec2.yaml
cp -p aws/ec2.py aws/ec2.ini %{buildroot}/usr/share/ansible/inventory/aws
cp -p gce/gce.py %{buildroot}/usr/share/ansible/inventory/gce
%files
+%config(noreplace) /etc/ansible/*
%dir /usr/share/ansible/inventory
/usr/share/ansible/inventory/multi_ec2.py*
-/usr/share/ansible/inventory/multi_ec2.yaml.example
/usr/share/ansible/inventory/aws/ec2.py*
%config(noreplace) /usr/share/ansible/inventory/aws/ec2.ini
/usr/share/ansible/inventory/gce/gce.py*